
Introduction: In this example you will model the velocity and temperature distribution over a heatsink. 
  
  

Problem Description:  
Units: Use S.I. units … meters ONLY  

Geometry: See figure.  
Boundary conditions: There is a two meter square and 1 meter tall space around the fin assembly  

Objective:  
To determine the flow around the object, temperature and velocity plots!.  
To determine the difference between constant wall temperature and constant wall flux conditions  

Figure:  
  

   

Problem repeated with:  
Constant wall flux  

Dimpled Fin's  

   

Basic Outline of the Problem: 
  
Preprocessing: 
1. Start ANSYS. 
2. Create volumes. 
3. Copy volumes to form heat sink fins. 
4. Define the fluid properties 

5. Define element type. (Flotran CFD 3D Flotran 142) 

6. Specify meshing controls / Mesh the areas to create nodes and elements.  
  
Solution: 

7. Specify boundary conditions.  
8. Solve. 
  
Postprocessing: 
Examine results! 
  
Exit: 
11. Exit the ANSYS program, saving all data. 
  
  

STARTING ANSYS 
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Click on ANSYS 6.1in the programs menu. Select Interactive. 
The following menu that comes up. Enter the working directory. All your files will be stored in this directory. Also enter 64
for Database. (more if you are working with extra memory) 

Click on Run. 

  

MODELING THE STRUCTURE 
  

Go to the ANSYS Main Menu  

Preprocessor>Modeling>Create>Volumes>Block>By 2Corners and Z.  
The following window comes up:  
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Enter the following data values to create the thin base of the heat generating volume.  
Next, we want to create the fins that will constitute the assembly. If you had hit APPLY instead of OK, then the window w
use Create Volume by 2 Corner and Z again to create the first fin.  

 

  
Now we want to copy the fin volume and paste it offset so that it is correctly positioned along the bottom of the fin assem
Preprocessor>Modeling>Copy>Volumes Select the volume to be copied. Next, the following window appears:  
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Enter the value for the offset, which is 0.009m and then click Apply. Note that the copy volumes dialog box on the left is
new volume and hit apply again. Hit apply in the window that appears because the offset is still 0.009. Continue until all
didn’t hit apply just start from Modeling>Copy>Volumes.  
The model should appear as below so far.  

 

Now, make the aluminum fin assembly one volume by using  Preprocessor>Modeling>Operate>Booleans>Add>V
the Dialog Box.  
Create one more volume, the control volume through which flow will pass. Modeling>Create>Volumes>Block>By D
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After this step it may prove useful to plot by lines. This will enable you to see everything more easily.  
Finally, subtract the aluminum fin assembly from the big box. Use Modeling>Operate>Booleans>Subtract>Volume
Select the box volume, hit OK, then select aluminum (this should only take one click!). Hit OK again and now you're done
The modeling is now finished. If you plot lines, and using Pan-Zoom-Rotate, select Obliq and hit the Fit button near th
figure should appear as the following. Also, if you plot volumes, rotate the model so you can see the underside, and then 
using WinZOOM, zoom in on the heat sink area, the second image is what you should see.. a HOLE!!  
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SELECTING ELEMENT TYPE: 

Click Preprocessor>Element Type>Add/Edit/Delete... In the 'Element Types' window that opens click on Add... Th

 

 Type 1 in the Element type reference number. 
Click on Flotran CFD and select 3D Flotran 142. Click OK. Close the 'Element types' window. 
So now we have selected Element type 1 to be a Flotran element. The component will now be modeled using the principle

finishes the selection of element type. 

  

DEFINE THE FLUID PROPERTIES: 
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Go to Preprocessor>Flotran Set Up>Fluid Properties.  
On the box, shown below, make sure all the input fields read Constant and then click on OK.  

  

Another box will appear, entitled CFD Flow Properties. Enter the values for Density, Viscocity, Conductivity, and Specific
temperature (Tw+Tinfin)/2 = (315+293)/2 = 304 K. 
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These values correspond to the following constant properties: 

  

<!--[if !vml]--><!--[endif]-->  
  
  

MESHING 
  

Go to Preprocessor>Meshing>Size Controls>Manual Size>Lines>All Lines. In the menu that comes up type .01
Length'.  

Density (ρ) 1.161 Kg/m^3
Dynamic Viscocity (μ) 1.873E-5 Kg/m*s
Conductivity (K) 0.0264 W/m*K
Specific Heat 1.0065E3 J/Kg*K
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Next, use Preprocessor>Meshing>Size Controls>Manual Size>Lines>Picked Lines. With the dialog window ope
constitute the control volume (all 12 edges). Hit OK. Enter 0.1 for 'element edge length'  
The line segments should look something like the following:  

 

   
Finally, use Preprocessor>Meshing>Mesh>Volumes>Free and mesh the volume. The result will look like the follow
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BOUNDARY CONDITIONS AND CONSTRAINTS 
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Hydrostatic: 

Go to Preprocessor>Loads>Define Loads>Apply>Fluid CFD>Velocity>On Areas. Notice the direction of the pos
apply a z-velocity so that the air will travel over the heatsink. In this case, we will apply a negative z-velocity to the
positive z-direction is towards the front face.  

  

 Enter -5 in the VZ value field and click OK. The value corresponds to a velocity of 5 meters per second of air flowing thro
Then, set the Velocity to ZERO (Vx=Vy=Vz) along the bottom area (the ground) and on all faces of the fin assembly.

ALL areas using the box command and then unselect the faces that constitute the ceiling and sides of the control volu
Go to Main Menu>Preprocessor>Loads>Define Loads>Apply>Fluid CFD>Pressure DOF>On Areas.  Pick all th

allowed to escape. This includes the end oppostie the applied velocity, both sides and the ceiling. (4 faces out of 6). 
Enter 0 as the pressure value.  (This sets the pressure as atmospheric allowing the air to pass out of the volume without 
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Thermal: 
  
NOTE: applying temperature boundary conditions can be difficult since the outside box is blocking the inside area

the areas that make up the large box get selected instead of, or in addition to the areas that make up the fin a
doesn't happen. Use the pan/zoom/rotate tool to check which areas are selected before applying boundary co
can always unpick areas by either clicking the right mouse button and then selected areas to be unpicked, OR
button on the 'Apply TEMP on Areas' box, and then selecting areas to unpick. 

Go to Preprocessor>Loads>Define Loads>Apply>Thermal>Temperature>On Areas  Since we can assume all th
base) are at room temperature (base acts like an insulator), we want to apply 293K to all areas except those that ma
all areas except the heatsink use the box command and draw a box around the entire volume. Then, select the 'Unpi
around the heatsink:  
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Before you click OK, make sure your screen looks like this. Notice 5 areas are selected. These areas are the top and 4 sid
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If your screen looks like the picture above, click OK and enter 293 in the screen that appears:  

 

Now you must apply a temperature to the surface of the heatsink. Looking at the results of the 3d heat sink conduction p
tutorial, anywhere between 300 and 315K is a good surface temperature. For this example 315K is choosen arbitraril
areas on the heatsink, use a similar method to the one described above.  

Loadings are now set, your model should look like this:  
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NOTE: IGNORE THE DIRECTIONS OF THE ARROWS. THEY ARE CORRECTLY DEFINED, JUST MISLEADING 

   
  

SOLUTION 

Go to ANSYS Preprocessor>Flotran Set Up>Solution Options and change the TEMP field to 'Thermal as shown:
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Go to ANSYS Main Menu>Solution>Flotran Set Up>Execution Ctrl.  
The following window appears.  Change the first input field value to 1000, as shown.  Also, change the velocity termi

(0.005).  Click OK.  
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Go to Solution>Run FLOTRAN.  
Wait for ANSYS to solve the problem.  

  

POST-PROCESSING 

Plotting the velocity distribution…  

Go to General Postproc>Read Results>Last Set.  
Then, go to the ANSYS Main Menu (the Top Bar) and Click Plot>Lines. 
 After the volumes have been plotted, go to the ANSYS Main Menu>WorkPlane and select WP Settings. Input .2
Now, select WorkPlane >Display Working Plane.  
Now that the working plane is selected, go to ANSYS Main Menu>WorkPlane >Offset WP by Increments and 

snap increment in the positive x axis and then rotate the working plane about the –Y axis 90 Degrees 

Once the plane is in line, select ANSYS Main Menu>PlotCntrls>Style…>Hidden Line Options..  a pop up window w
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In this window change “Type of Plot” to Q-Slice Z-buffer, and “Cutting Plane is” to Working Plane and click OK.  ANSY
of the analysis with the working plane as the cutting plane.  
Then go to General Postproc>Plot Results>Contour Plot>Nodal Solution. Select DOF Solution and Velocity an
The solution now looks like this:  
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Now goto General Postproc>Plot Results>Contour Plot>Nodal Solution and select Temperature distribution:
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Go to Main Menu>General Postproc>Plot Results>Vector Plot>Predefined. The following window will appea
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Select OK to accept the defaults.  This will display the vector plot of the velocity gradient. Remember to rotate the vie
best angle. 

Here is the vector plot from a few angles. 
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CONSTANT HEAT FLUX:  
   

If we repeat the same problem with a constant heat flux of 500 W/m^2 on the walls of the heatsink we get the following 
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To get a clearer plot of the temperature distribution you can change the range of temperatures that are plotted. Go to Ut
Menu>PlotCtrls>Style>Contours>Uniform Contours. In the window that appears select 'User specified' and then e

Página 25 de 373D Heat Sink Using Flotran



 

Your plot will now look like this:  

Página 26 de 373D Heat Sink Using Flotran



  
  

DIMPLED FIN HEAT SINK:  
   

If we repeat the problem with constant wall temperature of 315K, but this time use fins with small dimples on them we ge
increased surface area from the dimples. The dimples in the example are 2.5mm in diameter, and .5mm deep. There is a 
each side of the fin. To reduce the memory needed to compute the problem on 2 fins are used. There are a few different 
repeat this solution  

To ease the modeling of the dimpled fin, an IGS model of 1 dimpled fin is provided: dimpledfin.IGS  

Go to Utility Menu>File>Import>IGES. Unclick SMALL Delete small areas. Click OK. In the next screen select bro
the directory you saved it to and click OK.  
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When the file finishes importing your screen will look like this:  

 

Create the rest of the heatsink model the same way as before (create the base, copy the fin, add all the volumes to create
looks like this:  

Página 28 de 373D Heat Sink Using Flotran



 

The surrounding area can be smaller than before, I choose to make it 100mm larger than each side. Go to Modeling>Cr
Dimensions and enter the following numbers:  

 

Subtract the fin model from the large volume and the modeling is done:  
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To mesh this problem you need at least 500mb of RAM on your computer. Use an element size of 0.003 on all lines of the
element size of 0.1 on the 12 lines of the outer volume. You can use an element size less than 0.003 if you have more RA
of memory.  
Apply loads the same way as before.  
Flotran setup is the same as before.  
You should get the following results:  

Temperature distribution on a fin:  
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Temperature distribution 0.5 mm from a fin:  
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Temperature distribution in half way between the fins:  
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Top view of temperature distribution low down on fin:  

Página 33 de 373D Heat Sink Using Flotran



closeup:  

Página 34 de 373D Heat Sink Using Flotran



Top view high up:  
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Velocity distribution 0.5mm from a fin: 
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Saving Projects 
  
·          Simply go to Utility Menu>File>Save As… and save the project using the desired filename. To open the file later, run I

explained in this tutorial) as usual, and when that is done, go to Utility Menu>File>Resume From… and choose the save
saved in. 
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