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Load a body file  er-tut.bod  
    w Select File->Load->Bodyfile,  
    w Open file er-tut.bod, a 3D text  "EASY-ROB Robot Simulation Tool  AVI and HTML Tutorial" in red 
color appears  
   
How to use the mouse with 2 or 3 buttons  
    w EASY-ROB runs with a 2 and 3 button mouse  
    w Select Aux->Mouse Mode->2 Mouse Buttons if your mouse has only 2 buttons  
    w 3 Buttons mouse:  
        In principle the left mouse button - LMB represents the X direction or rotation about X,  
        the middle mouse button - MMB represents the Y direction  or rotation about Y and  
        the right mouse button - RMB represents the Z direction  or rotation about Z and  
    w 2 Buttons mouse:  
        In principle the left mouse button - LMB represents the X direction or rotation about X,  
        the right mouse button - RMB represents the Z direction  or rotation about Z and  
        the left and the right mouse button - LRMB together,  represents the Y direction or rotation about Y  

Rotate and translate the word view (viewpoint)  
    w Go with the mouse into the image,  
        - Pressing the LMB and moving from left to right and back will rotate the scene about the  
           Z-axis of the green colored word coordinate system.  
           Moving up and down will rotate the scene about the horizontal axis of your 'monitor'  
        - Pressing the LRMB and moving through the image will translate the scene  
        - Pressing the MMB (or RMB when 2 mouse buttons) will zoom in and zoom out.  

Reset viewpoint, set predefined view, load user views  
    w Select View->Set 3D Views->Reset View or click the Reset View Icon  
    w Select View->Set 3D Views->Top View will view the scene from the top  



    w Select View->Set 3D Views->Right View will view the scene from the right, etc.  
    w Select File->Load->Viewfile , open a view file *.vie, the scene interpolates to this user view  

Rendering: Bbox, wire frame and full shaded mode  
    w Select View->Render->Bounded Boxes will show all 3D geometries as bounded boxes  
    w Select View->Render->Wire Frame will show all 3D geometries in wire frame  
    w Note: Each 3D geometry has his own rendering attribute  

Floor manipulation  
    w Select Aux->Mouse Mode->Floor Color, will change the floor color with the mouse  
        - Note: Each color has an red, green and blue part. Values between [0..1]  
        - Pressing the LMB and moving from left to right and back will in- or decrease  the red part of the 
color  
        - Pressing the MMB (or LRMB when 2 mouse buttons) and moving from left to right and back will  
           in- or decrease  the green part of the color  
        - Pressing the RMB and moving from left to right and back will in- or decrease  the blue part of the 
color  
        - Note: EASY-ROB allows to save these environment setting, see below  
    w To change the size (length) of the floor and the number of squares (dlength)  
        - Select View->Grafic View Data  
        - Enter the values for the floor length and the floor delta length in [m]  

Background color manipulation  
    w Select Aux->Mouse Mode->Background Color, will change the background color with the mouse  
        - This works similar to the floor color modification, see above  
        - Note: EASY-ROB allows to save these environment setting, see below  

Save & edit the environment file  easy-rob.env  
    w The environment file easy-rob.env containes environment setting like floor color, floor size, 
background color  
        hither and yonder values for the clippping planes, 2 or 3 button mouse, ....  
        - File easy-rob.env and is loaded during start up of EASY-ROB.  
          This file is ASCII and can be edit also manually by the user  
        - Example:  
                ! ------------------------------------------  
                ! EASY-ROB Environment File easy-rob.env  
                !  
                ! Important:  
                !            Please do not change the order  
                !            off following statements  
                ! ------------------------------------------  
                FLOOR_ON 1  
                FLOOR_WIRE_ON 0  
                FLOOR_LENGTH 5.000000  
                FLOOR_DLENGTH 1.000000  
                FLOOR_COLOR 0.750000 0.750000 0.750000  
                BACKGROUND_COLOR 0.000000 0.000000 0.000000  
                HITHER 0.200000  
                YONDER 10.000000  
                VIEW_STEPS 5  
                2_MOUSE_BUTTONS 1  
    w To save the current setting in EASY-ROB  
        - Select  File->Save->Environment file  
    w To load the environment file  
        - Select  File->Load->Environment file  
    w To edit the environment file  
        - Select  File->Edit->EASY_ROB System files->Environment file  
        - Note: You can define your preferred editor in the configuration file config.dat, see below  



License file license.dat  
    w The license file license.dat containes the license key for EASY-ROB  
        - Example: EASY-ROB V2.3 GER980929 StefanAnton  ID-4460100043 hw_no:29268100 
exp.date:0000-00-00 0  
                         (the above license will only work on the computer with the hardware number 29268100)  
    w VERY IMPORTANT: EASY-ROB will not start if the license file 'license.dat' does not exist.  
    w Does the license file containes an invalid key, EASY-ROB will start as a demo version. With the 
demo version  
        the full functionality is available, but does not allow to save anything  
    w To edit the license file  
        - Select  File->Edit->EASY_ROB System files->License file  
        - Note: You can define the path where your license file resides on your computer in the  
                    configuration file config.dat, see below  
    w Get a license key for EASY-ROB  
        - If you have ordered EASY-ROB, I need your  
            1) Name, for example StefanAnton, see above  
            2) The hardware number: for example 29268100 in my case  
                Get your hardware number:  
                Select File->Edit->EASY_ROB System files->Get License Info , read you hardware number  
            3) I will send you your license key per email  

Configuration file config.dat  
    w The configuration file config.dat containes pathes of you working and grafics directories, your 
preferred editor, ...  
        - Example:  
                    ....  
                    WORKDIR= .\proj  
                    WORKDIR= .\proj2  
                    IGPDIR= .\igp_usr  
                    IGPDIR= .\igp_rob  
                    IGPDIR= .\igp_tut  
                    LICENSE= .\  
                    !  
                    !EDIT= my_editor -> your preferred editor  
                    !  
                    EDIT= notepad  
                    ....  
    w VERY IMPORTANT: EASY-ROB will not start if the configuration file 'config.dat' does not 
exist.  
    w To edit the configuration file  
        - Select  File->Edit->EASY_ROB System files->Config file  
   

Monitoring file moni_msg.txt  
    w The monitoring file moni_msg.txt protocols most importants thing what happens in EASY-ROB.  
        - Example:  
            If a 3D geometry is not load quite well (e.g. wrong polygons), take a look in this file.  
            If EASY-ROB is doing s.th strange, take a look in this file.  
            If an error occurs, email me the monitoring file  
    w To edit the monitoring file  
        - Select  File->Edit->EASY_ROB System files->Monitoring file  

Toolbars  
    w The Toolbars in EASY-ROB gives an fast access to the most needed functions  

Fig. Tut02 (Tollbars) 



        - Render Toolbar:  
            to enable or disable the light  
            to enable or disable the render mode wire frame for the complete scene  
            to enable or disable the render mode bbox mode for the complete scene  
            to enable or disable the render mode backface culling for the complete scene  
            to enable or disable the floor visualization  
            to enable or disable the floor render mode to wire frame  
            to reset the view  
            to toggle between Cell view and Igp-CAD View  

        - Run-Animation Toolbar:  
            to run, pause, continue, stop,  
            to enable or disable 'pause program execution after each motion command',  
            to enable or disable 'repeat program automatically',  
            to decrease or increase the simulation step size  
            to open output windows for miscell. values like joint and cartesian coordinates, current motion 
data, ...  

        - On-Off Toolbar:  
            to enable or disable the visualization of the robot,  
            to enable or disable the visualization of the robots tool,  
            to enable or disable the visualization of the environment bodies,  
            to enable or disable the TCP coordinate system (blue color)  
            to enable or disable the joint coordinate systems from each robot joint (yellow color)  
            to enable or disable all tag coordinate systems in the cell (different colors)  
            to enable or disable robot dynamics  
            to enable or disable the TCP trace (in green color for nominal path, red color for current path 
using dynamics)  
            to enable or disable 'Stop on limit switch', when joint travel ranges of robots are exceded  
            to open the program window (shows current executed program command)  
            to enable or disable hierarchical collision detection (bounded boxes, convex hul and concave 
bodies)  

        - Mouse Mode Toolbar:  
            to modify the view point (cruise, zoom in/out, translate),  
            to move the robot in cartesian coordinates related to the TCP frame,  
            to move the robot in cartesian coordinates related to the Robot Base frame,  
            to move the robot in joint space,  
            to move the robots base position,  
            to move the current selected body in cartesian space related to its base frame,  
            to move all bodies in a selected group in cartesian space related to a reference frame (tbd),  
            to move the current selected Tag point in cartesian space related to its own frame,  
            to enable or disable Translation (X,Y and Z-direction) or Rotation (RotX,RotY and RotZ-
direction),  
            to enable or disable TCP jog mode. (If this mode is on, the TCP location is kept its position when 
during modifying  
                the robots base position),  
            increments the mouse sensitivity  
            decrements the mouse sensitivity  

        - Move to Target Toolbar:  
            moves the robot to his homeposition in PTP mode,  
            moves the robot to a givin joint location in PTP mode,  
            moves the robot to a givin cartesian location in LIN mode,  
            moves the robot to a givin delta cartesian location in LIN mode,  
            moves the robot to a givin cartesian via point and cartesian target location in CIRC mode,  
            moves the robot to a givin delta cartesian via point and delta cartesian target location in CIRC 
mode,  
            moves the robot to one ore more tag points in a givin motion planner mode  



        - 3D CAD Toolbar:  
            to enable or disable the coordinate system from the current selected body (cyan color)  
            to select the next 3D CAD body in the current selected group (this body is the current selected 
one)  
                EASY-ROB has 3 groups for geometries:  
                Group 1:    Robot bodies  
                Group 2:    Tool bodies  
                Group 3:    Environment (Body) bodies  
            to enter or modify the absolute cartesian position of the current selected body  
            to enter or modify a relative cartesian position of the current selected body  
            to reset (undo) the cartesian position of the current selected body  
            to save the cartesian position of the current selected body  

   

   
 

• Load a cell file  arc_abb.cel.cel  
• Run the program (loaded with the cell)  
• Show the joint values during program execution  
• Show the program window during program 

execution  
• Close the joint value & program window  
• Load another robot irb24-10.rob  
• Modify the robots base position by -0.3m in -X 

direction  
• Save all joints and positions  
• Load tool file arc_gun.tol  
• Restart the program  
• Open the Teach Window, modify the program 

and restart  
• Save the Cell, give a new name => myfirstcel  
• Delete the current loaded cel, reload cell file 

myfirstcel.cel   
• Run the program (loaded with the cell)   

   

   
 

• 3D CAD Manipulations  
• Create a Block (Quader) 

chose a name and color  
• Modify the lengths of the block afterwards  
• Translate the Body with the mouse on the floor  
• Rotate the Body with the mouse  
• Reset bodies position to its initial location  
• Create a pyramide as second body  
• Invert the polygons from the pyramide  
• Set pyramide to wire frame  
• Select first body (Block)  
• Enter absolut values for location of the block  
• Enter relative values for location of the block  

   



   
 

• 3D CAD:  
• Build a table  
• Save the table as "IGP" Part file format  
• Reload the table  

   
   

   
 

• Create a robot  
• move the robot with the mouse in joint space  
• move the robot with the mouse in cartesian space   

   
   

   
 

• Create a new robot   
• Set up the robots attributes  
• Set the robots base position  
• Modify (play with) the robots kinematics lengths  

   
   

   
 

• Load a robot created in tutorial 6  
• Load the table from tutorial 4  
• Load a tool  
• Move the robot in cartesian space  
• Open the Teach Window  
• Teach a program and save it  
• Run the program  
• Save the Cell  

  


